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Technical Support
To request technical support, please contact us on the PTC eSupport Portal below. In your request please 
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Technical Support: http://support.ptc.com/

When reporting problems, please provide a test case and test procedure, if possible. If you are following up 
on a previously reported problem, please include the case number in the subject line of your correspondence.

Finally, please give us your e-mail address and telephone number so that we may contact you.
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1Introduction

Thank you for purchasing PTC X/Server. This book introduces you to the 
X/Server itself as well as the other programs that make up the PTC X/Server 
packages and gets you up and running quickly. You should read it if you 
want to use PTC X/Server on your PC to access UNIX applications.

As you read on, you.ll find out why PTC X/Server is the easiest way to 
access UNIX applications from Microsoft Windows.

What is PTC X/Server?
PTC X/Server provides Windows PC users with transparent access to X 
Window System applications running on remote host systems, as well as to 
UNIX character-based applications and or PTC MKS Toolkit ported UNIX 
applications running on Windows. It allows you to browse files on remote 
systems and launch applications with point and click simplicity. File transfer, 
printing and advanced messaging complete this connectivity package. PC 
users, whether in the office or on the road, can work with UNIX applications 
just as they do with Windows—all network and connection details are 
handled by PTC X/Server and kept hidden.

With PTC X/Server, you can:

 Run X Window System graphical applications or character-terminal (for 
example, VT420) applications on remote UNIX systems.

 Operate in the familiar, friendly environment of Microsoft Windows.

 Launch UNIX applications easily from Windows.

 Choose a Microsoft Windows look and feel for X applications, or use a 
standard X window manager for the look and feel of an X workstation.

 Suspend an X session and resume it later without closing X applications 
(if Vision Resume. is in use at your site).
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 Browse through files and folders and view the file hierarchy on UNIX 
systems in a similar way to browsing Windows files.

 Open UNIX-based documents from the Windows desktop.

 Copy information between UNIX applications and Microsoft Windows 
applications.

 Transfer files between your PC and UNIX systems.

 Create a virtual desktop space with multiple zones, with Windows and 
UNIX programs running in each, and switch between them.

 Print files from a remote host on a printer attached to your PC.

 Print from a Windows application on a printer attached to a UNIX 
system.

 Connect your PC to UNIX systems using a variety of different 
networks.

About This Manual
In Chapter 2, The Basics, you.ll find out what’s on the Windows desktop, 
and how to get more information from online Help. You’ll find out how to 
run UNIX applications, work with X programs and terminal emulators, and 
browse through UNIX files.

In Chapter 3, Beyond the Basics, you.ll discover how to turn your PC into an 
X display running your choice of window manager. You’ll also learn how to 
suspend and resume a session, organize files on a UNIX server, organize 
your desktop into zones, set up remote printing, and link UNIX data to a 
Windows document. Finally, you’ll see how you can fix PTC X/Server 
problems using the provided troubleshooters.
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2The Basics

This chapter gives a brief overview of how to get started with PTC X/
Server.

You’ll learn what’s in the Windows Start menu, and how to get more 
information from online help.You’ll find out how to run UNIX applications, 
work with X applications and terminal emulators, and browse through UNIX 
files.
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What’s on the Start Menu?
When you install PTC X/Server, the installer adds the UNIX Programs, New 
UNIX Program, and Run UNIX Program commands to the Start menu. 

Additionally, the PTC XServer folder in the Start menu’s Programs folder 
may contain some or all of the items shown in the following table, 
depending on installation choices. This folder is also called the PTC XServer 
Start menu.

Some items may be in sub-menus of the main PTC XServer menu,

Item Description

ANSI Emulator is an ANSI terminal emulator.

Audio Server provides X applications with the ability to 
send and receive audio data such as voice, sound 
effects, and music in a network environment. It can be 
found in the Accessories sub-menu.

UNIX Neighborhood can be used to browse remote 
hosts.
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Keymap Editor allows you to create and modify 
keyboard maps for use with terminal emulators. It can be 
found in the Accessories sub-menu.

Program Starter can be used to remotely execute a 
program on a UNIX server.

Help starts the PTC X/Server Help.It can be found in the 
Documentation sub-menu.

VT420 Emulator is a VT420 terminal emulator.

Wyse 60 Emulator is a Wyse 60 terminal emulator.

X/Server allows X Window System clients to display on 
your PC.

XVSpy is a troubleshooting tool that records and plays 
back an X protocol stream. It should be used under the 
direction of Customer Support and is not discussed in the 
PTC X/Server documentation. It can be found in the 
Accessories sub-menu.

Zones creates a virtual desktop space with several 
zones containing Windows and/or UNIX applications that 
you can switch between.

Item Description
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Getting Help
Online Help is the main source of information about PTC X/Server software. 
There are several different varieties of help available from the PTC XServer 
folder on the Start menu or from within the PTC X/Server programs 
themselves.

First of all, there is context help in the programs that describes what you see 
on your screen. This help is usually available by clicking on the ? in the 
program’s title bar and then clicking on the item about which you would like 
more information.

Second, there are the HTML Help files (launched from the Documentation 
sub-menu of the PTC XServer folder) which give more details about using 
the individual PTC X/Server programs. 

Finally, there are PDF documents (also launched from the Documentation 
sub-menu) such as this User Guide which provide introductory or advanced 
information that you can either read on-screen or print out for greater 
convenience.
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Running an X Program
For details of how to start and 
configure the X Server, refer to 
Chapter 3: “Beyond the Basics”.

The X Server must be running to allow you to display X programs on your 
PC. Normally, the X Server is launched by selecting X Server from the PTC 
XServer Start menu, although it can be configured to automatically run 
when you start Windows. By default, the X Server runs in multiple-windows 
mode, which means that the built-in Vision Window Manager is used and X 
clients have the look and feel of Microsoft Windows. If you want your PC to 
look like an X terminal, you need to use the X Server in single-window 
mode with a standard X window manager.

You can use Remote Program Starter to start X applications, residing any-
where on your network.

To Run an X 
Program

1. Click the Start button, and then click Run UNIX Program.

2. In the Host box, type a host name or choose a host from the drop-down 
list.

3. In the Command box, enter the command required to start an X 
program.

Do not include the -display option (because DISPLAY is set 
automatically), and do not type an ampersand (&) at the end. 
Alternatively, click the Browse button. If the Host box is empty, all the 
configured hosts will be displayed. If you specified a host in the Host 
box, then the contents of your home directory on that host will be 
displayed.Browse the host until you find the program or shell script you 
want to execute.

4. If you want to change other settings, choose a command from the 
Properties menu. You can get Help on an item by clicking the question 
mark button (?) in the title bar, then clicking the item.
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5. Click Run.

The X application should start in a few seconds. If it fails to appear, use 
the Help troubleshooters to help you identify the problem. Launch PTC 
XServer Help from the Documentation sub-menu of the PTC XServer 
folder on the Start menu and double-click Troubleshooting on the 
Contents tab.
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Running a Character-based Program
Character-based UNIX programs are designed to work with certain types of 
terminal, so to run a UNIX program from your PC you need to use one of the 
PTC X/Server terminal emulators. VT420, Wyse 60 and ANSI terminal 
emulators are provided, and most UNIX applications can be configured to 
use one of these terminal types.

To Run a 
Program from a 
Terminal 
Emulator

1. Launch the desired terminal emulator by clicking ANSI Emulator, 
VT420 Emulator, or Wyse 60 Emulator in the PTC XServer folder of 
the Start menu.

2. On the Session menu, click Connect.
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3. In the Host box, type a host name or choose a host from the drop-down 
list.

4. In the Username box, type a username or chose one from the drop-
down list.

5. In the Command Line box, enter the command required to start a 
program, or leave the box empty if you want to log in to the UNIX host 
manually. If you want to see the UNIX system prompt, then enter the 
name of a shell program such as sh or csh.

Alternatively, click the browse button (...) to browse the UNIX 
neighborhood for a host and or command. If no host is specified, all 
hosts are shown. If the Host entry already specifies a host, your home 
directory on that host is shown. Browse until you find the program or 
shell script you want to execute.

If you entered a program name, then a connection is opened to the 
UNIX host, you are logged in automatically, and the program is started. 
If you specified a shell program, then the UNIX system prompt appears 
and you can interact with the system in the same way as if you logged in 
at a real terminal. If you left the Command Line box empty, then a 
connection is opened, and you will see the UNIX Login prompt asking 
you to log in manually, after which you will see the system prompt 
produced by your default login shell. If you specified a program that is 
not a shell, then you will see that program as soon as the automatic 
connection and log in process has completed.
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Creating a UNIX Program Item
The UNIX Application Wizard can be used to create a Windows desktop 
item that allows you to start an X application or a character-based 
application. The wizard will either add the application to the UNIX 
Programs menu on the Start menu, or create a new icon on the desktop or in 
a folder, depending on how you started the wizard. You can also include 
settings files in your Web pages.

To Create a UNIX 
Program Desktop 
Item

1. Do one of the following:

 f you want the application to appear on the Start menu, click the 
Start button, and then click New UNIX Program.

 If you want the application to appear as an icon on the desktop or in 
a folder, click with the right mouse button where you want the item 
to appear, click New, and then click UNIX Program.

2. Follow the wizard’s instructions, choosing the host and the command to 
be executed. You can use the Browse button to find the executable file 
you want.
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3. You are asked to choose the type of program. Other means a UNIX 
program that does not require a user interface.

4. The wizard asks if you want to test the application. Be sure that the 
command will not make unwanted changes on the host system before 
you execute it.

If the application is an X client then the Host Replies window is 
displayed to show status messages including any error messages 
produced by the host operating system. The X client should then appear.
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5. If the command produces an error, it will be displayed by the wizard. 
For most common errors you can select the error in the list box and click 
the Help button for assistance with that specific problem. You can click 
the Back button to return to previous settings, and then try executing the 
program again.

6. The wizard prompts you for an application name, which is used as the 
name of the settings file.

The UNIX Application Wizard creates either a Remote Program Starter 
document (.rps) or a terminal emulator document (.v42, .ans, .w60). 
If you ran the wizard from the Start menu, then the application is added 
to the list of UNIX programs on the Start menu. If you ran the wizard 
from the desktop, then a new icon appears. If you ran the wizard from 
inside a folder, then the settings document appears in the folder.
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Working with X Applications
For more information, see 
“Running an X Program” on 
page 7.

This section provides some basic information about working with X 
applications once they have been started and are displayed on your PC 
screen.

Copying and 
Pasting Between 
X and Windows

You can easily copy and paste information between X clients and Windows 
applications. These instructions assume that you have not altered the default 
Clipboard settings in the X Server profile.

To Copy and Paste Information

1. Select the information in the X application by dragging over it with the 
mouse. This action copies the information to the Windows Clipboard.

2. In the document where you want to insert the information, position the 
input cursor where you want it to appear.

You can also copy and paste 
information in a terminal 
emulator. For more information, 
see

3. On the Edit menu, click Paste.

The new information appears in the document.
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Tip To paste information from the Clipboard to an X application, position the 
cursor and then click both mouse buttons at the same time.

Using Font 
Substitution

By default, font substitution is enabled so that if an X application requests a 
font that is not available on your PC (or a font server) then the X Server will 
silently substitute another font. If you prefer to have more control over font 
substitution, then click Interactive on the Fonts tab in the X Server 
Properties dialog box. Interactive font substitution can be for a single 
request, for all requests in a session, or permanent. In order for permanent 
font substitution to be used the Global Aliases item must be in the Font 
Path Items list.

When an application requests a font that is unavailable, a dialog box is 
displayed showing the suggested substitution.
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You can either accept the suggestion, or choose another font from the 
Suggestions list. If the initial font suggestions list does not contain a 
suitable font, then a manual search of all available fonts can be carried out. 
Enter the search pattern in the Pattern box, using wildcard characters if you 
wish. You could copy part of the logical font description from the Font Not 
Found box to the Pattern box using standard Windows copy and paste 
techniques. Select the text you want to copy, then press CONTROL+INSERT. 
Select the destination, then press SHIFT+INSERT. Click Suggest to show 
the new suggestions list.
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Working with a Terminal Emulator
For more information, see 
“Running a Character-based 
Program” on page 9.

This section provides some basic information about working within a termi-
nal emulator once you have opened a connection and run a UNIX program.

Copying and 
Pasting 
Information

As you work, you often need to copy information from one document to 
another, or from one place to another within a document. Before you edit 
information, you must select (highlight) it. Place the mouse pointer where 
you want to start selecting. Then press and hold down the mouse button, and 
drag the pointer to where you want the selection to end. Then release the 
mouse button.

To copy information

1. Select the information.

2. On the Edit menu, click Copy.
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3. In the document where you want to insert the information, position the 
input cursor where you want it to appear.

4. On the Edit menu, click Paste.

The new information appears in the document.

Tip You can also copy information from a UNIX document to a PC document, 
or vice versa.

Changing the 
Font

By default, the font size changes as you resize the emulator window. The 
intention is to display as much as possible of the virtual screen (for example, 
80 columns by 25 rows) in the window. If the whole of the virtual screen 
cannot be displayed, then scroll bars are added to the window. This section 
tells you what to do if you prefer to work with a fixed font size that does not 
change as you resize the window.
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To Change the Font
You can get Help on an item by 
clicking the question mark button 
in the title bar, then clicking the 
item.

1. On the Properties menu, click Font.

2. In the Font size box, click the size of font you want.

3. Click Font varies with window size, so that the box is not checked.

Changing Text 
Attributes

The default colors are white text on a black background. You can change the 
background color, and colors for normal text, and text with attributes such as 
bold or flashing. Note that if you specify colors or other text attributes, these 
will override any specified by the UNIX application.



The Basics

20 PTC X/Server

To Change Text Attributes

1. On the Properties menu, click Attributes.

2. In the Item box, click the item you want to change color.

3. In the Map Item To section, select the Color check box. The Fore and 
Back buttons below become enabled. Click a button to display the 
available colors, then choose the color you want.

Tip Instead of using the Item box, click what you want to change in the preview 
screen.
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Seeing What’s on a UNIX Server
You can browse the files and folders on a UNIX computer.

Browsing UNIX 
Servers

You can use UNIX Neighborhood to see what’s on a UNIX computer.

To See What’s on a UNIX Server

1. Select UNIX Neighborhood from the PTC XServer Start menu.

2. A window appears, displaying icons for all UNIX servers on your local 
network to which you can connect.

3. Double-click the icon for the host you want to browse.
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4. If this is the first time you have connected to this host, you will be 
prompted to enter a username and password.

A window appears showing the contents of your home folder on the host.

To See the Hierarchy of Folders

1. Select UNIX Neighborhood from the PTC XServer Start menu.

2. Click a host in the left side of the window. If this is the first time you 
have connected to this host, you will be prompted to enter a username 
and password. The tree is then expanded to show the contents of your 
home folder on the host.
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The right side of the window displays the contents of the item you click on 
the left.

Recognizing 
Different Types of 
Files

Folders and files are displayed in UNIX Neighborhood using several 
different icons including:

Some other file types with distinctive icons are configured by Setup, and 
you can add your own.

This Icon Represents

A folder, which can contain files and other folders.

A file. The documents you use and create are files, and 
so are the programs you use. Different types of files may 
have different-looking icons. This standard (generic) icon 
is used when a file type does not have a specific icon 
associated with it.

A program that runs in an ANSI terminal emulator. 

A program that runs in a VT420 terminal emulator.

A program that runs in a Wyse 60 terminal emulator.
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Opening a 
Program or 
Document

You double-click icons to see the contents of a folder or to start a program or 
open a document.

To Run a Program or Open a Document from UNIX 
Neighborhood

In UNIX Neighborhood, find the file you want to open, and then double-
click it.

If the file is recognized as an executable program, then the appropriate 
terminal emulator or remote program starter is run on the PC, which then 
executes the program on the UNIX server. If the file is a document, then the 
document is loaded after the UNIX program starts.

If the file is not recognized as one of the registered file types, then the Open 
With dialog box is displayed for you to choose the application used to 
display the file.
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Changing the 
Appearance of 
the Window

You can change the appearance of windows.

To Change the Appearance of the Window

On the View menu, click the Small Icons, List, or Details commands.

This is the Large Icons view.

Tip To see a description of what each menu command does, click the View 
menu, and make sure there is a check mark next to the Status Bar command. 
Then when you rest your mouse over a menu command, information about the 
command appears at the bottom of the window.

Displaying the 
Previous Folder

You can display the previous folder.

To display the previous folder

1. If the toolbar is not visible, click View, and then click Standard.

2. On the toolbar, click the Up Folder button or press the BACKSPACE key.
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3Beyond the Basics

Once you’ve mastered the basics, you’ll want to know more about 
configuring PTC X/Server and how to use more of the advanced facilities.

In this chapter, you’ll discover how to turn your PC into an X display 
running your choice of window manager, how to suspend and resume a 
session, how set up remote printing, and how to use PTC X/Server to 
organize files on a UNIX server too.
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Configuring PTC X/Server
You can use the Configuration sub-menu of the PTC XServer Start menu to 
change settings for:

 PTC X/Server Communications

 PTC X/Server Services

 PTC X/Server Profiles

You can configure the basic communications layer, and also the higher-level 
services that are only available if SCO Vision2K software is installed on the 
UNIX host. Configure PTC X/Server profiles to specify options for the X 
Server.

To Configure PTC X/Server from the Start Menu

1. From the PTC XServer Start menu, select Configuration.

2. Click PTC X/Server Communications, PTC X/Server Services, or 
PTC X/Server Configuration.

The following sections describe each of the three types of configuration. 

Configuring PTC 
X/Server 
Communications

The PTC X/Server Communications settings are used to configure the 
following:

 Hosts, to which you can connect and run UNIX programs.

 Transports, used to connect the PC to remote UNIX hosts.

 Database, that provides access to the PTC X/Server Communications 
database.

 Diagnostics, that provide troubleshooting information.

You should not need to change any of these settings.

Host Finder will detect all hosts running SCO Vision2K software as well as 
hosts running the X Display Manager (xdm) daemon. By default, the 
transport used to connect to the host will be chosen automatically from those 
available when the connection is opened.
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Configuring PTC 
X/Server Services

The PTC X/Server Services settings are used to configure the following:

 General, that allows PTC X/Server Services to be started or shut down 
manually, and allows you to prevent the banner being displayed at start 
up.

 LNA, that allows the PC to launch server programs on demand.

 Host Finder, that detects remote hosts and configures them 
automatically.

 Printing, that provides local and remote printing services.

By default, Host Finder detects all UNIX servers that have SCO Vision2K 
software installed, and hosts running the X Display Manager (xdm) daemon. 
You enable or disable categories of hosts by clicking the check boxes in the 
Host Types box. You should not need to alter settings in the LNA or Admin 
tabs, and the Printing settings are discussed later in this chapter.
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Configuring PTC 
X/Server Profiles

The PTC XServer Configuration menu item (in the Configuration sub-
menu of the PTC XServer Start menu) allows you to configure the various 
properties of PTC X/Server including the following:
 General settings, that allows you to create or modify profiles, and 

specify a profile to use when the X Server starts.

 Global settings, that allow you to specify whether the X Server should 
be started when Windows starts, and some security options.

 Web settings, that allow you to specify an X firewall proxy, recognized 
web servers, and control the profile used when starting an X client from 
an RX document.

The X Server properties control how the server looks and behaves, and how 
X clients should appear on the screen. 

Normally, when you launch PTC X/Server Configuration, you are editing 
the default X Server profile. If you make changes and click Save on the File 
menu, those changes will be made to the default profile.

Use the icons and the Manage menu to configure the various server 
properties. Some options only become applicable when you choose another 
option. When options are not applicable, they appear grayed in the dialog 
boxes. If grayed options become available again, they show the built-in 
default settings
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You can also use PTC X/Server Configuration to create new profiles and 
make changes to a profile that already exists.

To Create a New Profile

1. Select PTC XServer Configuration from the Configuration sub-menu 
of the PTC XServer Start menu. The PTC X/Server Configuration 
dialog box appears.

2. Select New from the File menu.

3. Set the various properties desired for the new profile.

4. Select Save As... from the File menu. The Save Copy As dialog box 
appears. Enter a name for the new profile in the File name: box and 
click Save.

To Configure An Existing Profile

1. Select PTC XServer Configuration from the Configuration sub-menu 
of the PTC X/Server Start menu. The PTC X/Server Configuration 
dialog box appears.

2. Select Open... from the File menu. The Open dialog box appears. Select 
the profile to be configured and click Open.

3. Make the desired changes to the profile.
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4. Click Save on the File menu, to save the changed profile. As an 
alternative, you could select Save As... from the File menu to save the 
modified profile under a new name. 

Note You can run multiple instances of the X Server, using different profiles, 
providing you specify a different X Display Number for each profile. However, 
you can only run one multiple-windows mode session.

Configuring an X 
Server that is 
Running

You can configure a currently-running X Server by changing its properties.

To Configure an X Server that is Running

Do one of the following:

 If the server is running hidden, click the X Server icon in the 
notification area of the taskbar with the right mouse button, and then 
click Properties.

 If the server is not hidden, click the X Server on the taskbar with the 
right mouse button and click Properties.

 If the server is running in single window mode, select Configuration 
from the PTC X/Server Start menu and click PTC XServer 
Configuration.

A dialog box appears, with the name of the current profile displayed in the 
title bar. Use the tabs to switch between the various server properties. To 
save changes and close the properties dialog box, click OK. For changes to 
take effect before you close a properties dialog box, click Apply. Most 
changes you make take effect immediately, but others (such as changing the 
display mode) require you to restart the X Server. If this is necessary, a 
dialog box is displayed asking whether you wish to restart the server now. If 
this is a convenient time to restart the server, choose the Yes button. If you 
have active clients, you may prefer to choose No, close down your clients, 
and then restart the server using the Restart command on the Control menu.

Switching X 
Server Profiles

When you edit a profile, it has no effect on any currently running X Server 
started with that profile. However, if you change the properties for a running 
X Server, those changes are saved to the profile and will be in effect the next 
time you use the profile to start an X Server.
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Normally, when the X Server is started, the default X Server profile is used. 
To change the profile used, select PTC XServer Configuration from the 
Configuration sub-menu of the PTC XServer Start menu. When the PTC X/
Server Configuration dialog box appears, click on the Default Profile icon. 
The When starting PTC X/Server dialog box appears.

To always load a particular profile when the X Server starts, select the 
Always use this profile: option and choose the desired profile from the 
dropdown list. Otherwise, you can select the Prompt for a profile to be used 
option and the X Server will ask you to select a profile to use each time it 
launches.

Starting the X 
Server

The X Server is normally launched by selecting X Server from the PTC 
XServer Start menu. If you want the X Server to start automatically each 
time Windows starts, select PTC XServer Configuration from the 
Configuration sub-menu of the PTC XServer Start menu. When the PTC 
XServer Configuration dialog box appears, select Global Settings from the 
Manage menu, and enable the Load PTC X/Server At Windows Startup 
option. The server may also start automatically if it is not running when you 
use the Program Starter to run an X client.

To Start the X Server Manually

 Select X Server from the PTC XServer Start menu.

The server starts, and if it is configured to run hidden, then an indicator 
appears in the notification area of the Windows taskbar. If you have changed 
the configuration, then the server may appear as an icon on the taskbar or as 
a window.
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Windows Management
The profiles created when you installed PTC X/Server run the X Server in 
multiple-windows mode, which means that each X program appears in its 
own Microsoft Window. The VWM window manager built in to the X 
Server is used to manage X clients. This gives X programs the look and feel 
of Microsoft Windows.

If you prefer to make your PC resemble a standard X display, then you can 
run the X Server in single-window mode. X applications appear within a 
single Microsoft window, which can be made to fill the entire PC screen.You 
can use a standard X window manager such as the local Motif MWM 
supplied with PTC X/Server, or a host-based window manager such as CDE, 
KDE, GNOME, OPEN LOOK OLWM, HP-VUE or DECwindows.

Tip To use the local MWM window manager supplied with PTC X/Server, you 
need to install it using the Custom or Repair options of the PTC X/Server 
installer and then enable it in the Advanced Single-Window Mode dialog box.

To Create a Profile for Single-window Mode

1. From the PTC XServer Start menu, select Configuration, and click 
PTC XServer Configuration.On the File menu, click New. This creates 
a new profile based on the default PTC NuTCRACKER Platform 
profile.
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2. Click Display.

3. Click Single Window.

Tip Clicking the Advanced button allows you to set other options, such as 
making the X Server fill the PC screen. For Help on an item in a dialog box, 
click the question-mark button in the upper-right corner, and then click the item.

If you want to use X Display 
Manager to start an X session, 
look up XDMCP in the Help 
index.

4. Click OK, and in the PTC X/Server Profiles dialog box, either specify 
that Single should always be used as the profile when starting the X 
Server, or ask to be prompted.
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Suspending and Resuming a Session
Vision Resume allows you to suspend an X session and resume it at a later 
time. The main benefits are:

 X clients that are part of a Resume session actually run via a 
“proxyserver” on a UNIX host.

 The proxy-server communicates with the X Server running on a PC to 
display output and receive user input.

 A session can be suspended at any time either by user action, or through 
an unscheduled event such as communications failure. The X clients 
that are part of the session continue to run on the proxy-server.

 When a session is resumed, the X clients that were previously running 
reappear on the PC display and you can continue to work with them.

 There is only one Resume session for a UNIX user, so a session can be 
resumed on the same PC or a different PC.

 An X session can be relocated to a different display at any time.

Configuring 
Vision Resume on 
the PC

Vision Resume is configured by changing the properties for an X Server 
profile. You can display properties either by selecting PTC XServer 
Configuration from the Configuration sub-menu of the PTC XServer Start 
menu, or for the current X session by using the X Server’s Control menu. By 
default, the option to use Vision Resume is disabled. Vision Resume must 
also be installed and configured on your UNIX server (ask your System 
Administrator).
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To Configure Vision Resume on the PC

1. In the X Server properties dialog box, select All Properties and click 
the Vision Resume tab.

2. Choose the Use Vision Resume option.

3. In the Resume Host box, choose the host on which the Vision Resume 
proxy-server will run. If you leave this box empty, then you will be 
prompted for a host when you start a Resume session.

4. Choose the Let PTC X/Server Automatically Manage My Resume 
Session option if you want a Resume session to be started 
automatically when the X Server starts.

Controlling a 
Vision Resume 
Session

If the Let PTC X/Server Automatically Manage My Resume Session 
option is enabled, then when the Vision X Server starts, any existing session 
will be resumed or a new session will be started.

You can also start or resume a session manually.

To Control a Vision Resume Session

1. Do one of the following:
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 If the server is running hidden, then click the X Server icon in the 
notification area of the taskbar with the right mouse button and click 
Vision Resume.

 If the server is not hidden, click the X Server icon on the taskbar 
with the right mouse button and click Vision Resume.

 If the server is running in single-window mode, click the Control 
menu and then click Vision Resume.

2. If a Resume Host has not been specified in the X Server profile, then 
you will be prompted to choose one. If the profile specifies the Resume 
host then you will not see this dialog box.

If you want to set this Resume Host name in the X Server profile, click 
the check box.

For more information, look up 
“Vision Resume” in the Help 
index.

3. When the Vision Resume Session Control dialog box is displayed, 
click the action you want.

A connection is opened to the Resume host. If you are starting a new 
Resume session, then the X clients specified in your session file are 
started.
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Organizing Files and Folders
This section details some procedures for working with files and folders on a 
UNIX server, and for copying files between your PC and a UNIX server. 
This is normally done using UNIX Neighborhood.

Using UNIX 
Neighborhood

You can move or copy files within one UNIX file system; from one UNIX 
system to another; or between a UNIX system and your PC.

To Move or Copy Using the Edit menu

1. Click the file or folder you want to move or copy. You can click a UNIX 
file or folder in UNIX Neighborhood, or a Windows file or folder in My 
Computer.

2. To move the file, select Cut from the Edit menu. To copy the file, select 
Copy from the Edit menu.

3. Open the folder where you want to put the copy. You can open a UNIX 
folder in UNIX Neighborhood, or a Windows folder in My Computer.

4. On the Edit menu, click Paste.

Tip To select more than one file or folder to copy, hold down the CTRL key, 
and then click the items you want.



Beyond the Basics

40 PTC X/Server

To Move or Copy by Using the Right Mouse Button

1. Use the right mouse button to click the file you want to move or copy. 
You can click a UNIX file in UNIX Neighborhood, or a Windows file in 
My Computer.

2. To move the file, click Cut. To copy the file, click Copy.

3. Open the folder where you want to place the file. You can open a UNIX 
folder in UNIX Neighborhood, or a Windows folder in My Computer. 
Then use the right mouse button to click an empty part of the window.

4. Click Paste.
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To Delete a File or Folder

1. In UNIX Neighborhood, click the file or folder you want to delete.

2. On the File menu, click Delete.

You can also use UNIX Neighborhood to create new folders.



Beyond the Basics

42 PTC X/Server

To Create a New Folder

1. In UNIX Neighborhood, open the folder where you want to create the 
new folder.

2. On the File menu, point to New, and then click Folder.

3. The new folder appears with a temporary name.

Tip To set properties for the new folder, click Properties on the File menu.

4. Type a name for the new folder, and then press ENTER.
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Printing
PTC X/Server allows Windows and UNIX applications to share printers. 
You can print from a UNIX application to a printer attached to a PC, or you 
can print from a Windows application to a UNIX printer.

In addition, some PTC X/Server terminal emulators have slave printing 
capabilities, just like the real terminals they emulate. 

Printing UNIX 
files on your PC

The Print Server on the PC listens for print requests, and prints them on a 
local printer attached to your PC. A local printer called Default is set up for 
you when you install PTC X/Server, configured to use the standard LPD 
print service that many versions of UNIX support over TCP/IP network 
connections. To be able to send print requests, the System Administrator 
needs to configure the PC printer as a remote printer on your UNIX host.

To Change the Local Printer Type

1. Select PTC XServer Services from the Configuration sub-menu of the 
PTC XServer Start menu, and click the Printing tab.

2. In the Printers box, click Default, and then click Edit.
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3. In the Printer Type box, choose RPC Protocol from the drop-down list.

4. Make any changes you want to the other options.

Printing PC Files 
on UNIX

PTC X/Server allows you to print from a Windows application to a printer 
attached to a remote UNIX server. Print jobs will be scheduled by the UNIX 
spooler. The Print Server on the PC also acts as a client program to send 
print requests to the print server on the UNIX host. You can choose whether 
the client sends print requests using the LPD protocol, or using the Vision 
USP RPC protocol.

Configuring a remote UNIX printer involves three separate actions:

1. On your UNIX host, set up the printer which is to receive printing 
requests from your PC. For example, the printer might be called 
room123.

2. Add a new Windows printer that sends its output to a file on the PC.

3. Configure the remote printer in PTC X/Server Services.

When you have configured the remote printer, you will be able to print to it 
by choosing it in your Windows application, just like any local printer.
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To Add a Printer on Windows XP

1. On the PC, select Printers and Faxes from the Start menu.

2. Click Add a Printer.
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3. The Add Printer wizard starts, and you should follow the instructions to 
set up a new printer. Choose Local Printer, and then select the type of 
printer attached to the UNIX system. When you are asked to choose a 
port, none of the existing ports are suitable for remote printing, so 
temporarily select LPT1:. Specify a meaningful printer name, for 
example QMS-PS810 on UNIX. Do not choose to print a test page.

4. When the wizard has finished, the new printer appears in the Printers 
window.

5. Click the new printer icon with the right mouse button, and click 
Properties.
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6. On the Ports tab, click Add Port.

7. Click Other, and select Local Port in the list box. Click OK.

8. Type a filename as a new port name. For example, 
c:\tmp\unixprt.tmp. Click OK.

9. The new “port” will now be shown in the Print to the Following Port 
box. Click OK to exit from the Printer Properties dialog box.

You can now proceed to add a remote printer in PTC X/Server Services, as 
described later in this section.

To Configure a Remote Printer in PTC X/Server Services

1. Select PTC XServer Services from the Configuration sub-menu of the 
PTC XServer Start menu.

2. Select the Printing tab and click Add Remote.

3. In the Logical Printer Name box, type a new name.

4. In the Physical Printer Name box, choose the Windows printer you just 
set up (for example, QMS-PS810 on UNIX on 
c:\tmp\unixprt.tmp.).

5. Specify the name of the remote host, and the remote printer (for 
example, room123).
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6. Specify the communications protocol (LPD or RPC) by which print data 
will be sent from your PC to the selected UNIX host. If the UNIX host 
handles incoming LPD remote printing requests, and your PC is able to 
establish a TCP/IP connection to the UNIX host, select LPD Protocol; 
otherwise select RPC Protocol. If you are using LPD protocol, you may 
have to add your PC’s network name to the /etc/hosts.equiv or /
etc/hosts.lpd file on the host (refer to the LPD documentation on 
the host).
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Putting a UNIX Shortcut on the Desktop
In Windows, shortcuts provide easy access to the documents and programs 
you use most often. PTC X/Server lets you put shortcuts to UNIX items 
directly on the Windows desktop. You can create a shortcut to a folder, a 
program or a document.

Creating a shortcut does not change the file’s location on the UNIX server, 
and does not copy it to the PC. When you delete a shortcut, the original file 
is not deleted. If you delete the file, the shortcut is not deleted automatically.

To Put a Shortcut on the Desktop

1. Drag an icon from UNIX Neighborhood to the desktop.

Double-clicking on a folder shortcut starts UNIX Neighborhood to 
display the contents of the folder. Double-clicking on a program 
shortcut starts the program, and a document shortcut starts the 
associated program with the document loaded.

Starting UNIX 
Programs 
Automatically

You can have a UNIX program start automatically when you start Windows.

To Make a UNIX Program Start when Windows Starts

1. Create a Windows desktop item (on the desktop, not in the Start menu) 
that lets you start an X application or a character-based application.

For more information, see 
“Creating a UNIX Program Item” 
on page 11.

2. In Windows Explorer, display the Startup folder.

3. Use the right mouse button to drag the document icon into the Startup 
folder. Release the mouse button.
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4. Click Create Shortcut(s) Here.

The program specified by the shortcut will be started each time you start
Windows.
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Organizing the Desktop with Zones
For more information, look up 
“Zones” in the Help index.

You can use the Zones program to organize your desktop. Applications that 
are currently running can be grouped into zones that you can easily switch 
between. When you start Zones, the zonebar appears at the top of the PC 
screen.

The Zones button on the left displays a menu. The other buttons represent 
the different zones. You can change the names of the zones, move the 
zonebar to a different location, or hide it in the same way that the Windows 
toolbar can be hidden. The Windows desktop remains visible in all zones.

All programs running when you start Zones are placed into Zone 1. Click a 
zone button if you want to switch to a different zone, and start any 
applications you want to appear in the new zone. You can start local 
Windows applications, or use other PTC X/Server programs to start UNIX 
applications.

Each zone has a StartUp folder to allow you to specify programs that should 
be started when you first enter a zone.
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Using SSH with PTC X/Server
For details on configuring and 
using SSH with PTC X/Server, 
select Documentation from the 
PTC XServer Start menu and 
click Using SSH with PTC X/
Server. 

SSH (Secure Shell) is a secure replacement for older TCP protocols such as 
rexec, rsh, rlogin, telnet, and ftp. SSH provides the functionality of 
these older protocols while adding the security of an SSL encryption layer 
and support for modern authentication mechanisms. You can also use an 
established SSH connection to tunnel other protocols (such as X11) over the 
existing channel.

PTC X/Server provides transports that use older connection mechanisms as 
well as ones that use SSH. As a result, you can connect to both pre-SSH 
machines and SSH-capable machines. PTC X/Server first tries to connect 
using SSH and if that fails, it falls back to using an insecure transport (for 
example, telnet) to make the connection.

SSH can be configured to use a variety of authentication methods. By 
default, PTC X/Server is configured the simplest authentication method 
(where you are always prompted for your username and password when you 
connect to a UNIX machine). PTC X/Server can also be configured to use 
RSA/DSA Public Key Authentication or Smart Card Authentication.

One of the most popular reasons to use SSH is that it allows passwordless 
authentication. In other words, once you have set up passwordless 
authentication, you can open secure connections without providing your 
password each time. To set up passwordless authentication, you must 
generate a pair of public and private keys using the ssh-keygen utility 
(available with PTC MKS Toolkit and on most UNIX systems) and copy 
them to the machine to which you want to connect. Where precisely you 
copy your key depends upon the specifics of the secure shell service or 
daemon running on the remote machine.

If you are connecting to a secure shell service or daemon that is derived from 
the OpenSSH version of secure shell (such as the secure shell service (sshd) 
from PTC MKS Toolkit), you should append protocol version 1 RSA keys to 
the host’s ~/.ssh/authorized_keys file and protocol version 2 RSA 
and DSA keys to the host’s ~/.ssh/authorized_keys2 file where ~/ is 
the home directory of the account on the remote host.

If you are connecting to a secure shell service or daemon that is derived from 
the ssh.com version of secure shell, the procedure is somewhat different. The 
first thing you must be aware of is that the format of the public key files that 
are used by these secure shell daemons is different than the format that is 
used by the OpenSSH derived versions. Fortunately ssh-keygen can 
convert these for you with a command like:

ssh-keygen –e –f ~/.ssh/id_dsa > dsa2.pub
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In this example, the file dsa2.pub is the file that contains the public key and 
should be installed on the remote server. Typically this is done by simply 
copying the file to ~/.ssh2/dsa2.pub — the ssh.com versions of the 
service keep each public key in a separate file. Finally you need to append a 
single line to the file ~/.ssh2/authorization:

Key dsa2.pub

If you are using PTC MKS Toolkit to create the private key, the key is placed 
in the correct location. Otherwise, you should use the Identity tab of the 
Secure Shell Client Host Configuration dialog box during SSH 
configuration to import the private key and place it in the correction location.

Once you have done this, passwordless authentication should be enabled.

When connecting to a remote host using SSH, you may leave the password 
field empty. If the password is entered, it is cached and no further username/
password dialogs will show up for that host. If no password is entered, the 
SSH layer may or may not prompt for a password. Such a password is never 
cached in the password database, so every connection that is opened will 
prompt again for a password. If you are using passwordless authentication, it 
is appropriate to not enter the password at the username/password dialog.
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Troubleshooting
If you encounter problems when using PTC X/Server software, select 
Troubleshooting in the table of contents for PTC X/Server Help, and follow 
the step-by-step instructions to resolve the problem. In addition, PTC X/
Server Help gives information about how to contact Technical Support if 
you cannot resolve your problem.


